Среда, 20.09.2017, 17:35
Приветствую Вас Гость | RSS

Подготовка к ГИА по информатике

Меню сайта
Статистика

задания типа 9 (часть 6)

45.Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  a, k

a := 40

нц для k от 2 до 5

a := a k

кц

вывод a

кон

Бейсик

DIM a, k AS INTEGER

a = 40

FOR k = 2 TO 5

a = a k

NEXT k

PRINT a

Паскаль

var a, k : integer;

begin

a := 40;

for k := 2 to 5 do

a := a k;

write(a);

end.


46. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

цел  a, k

a := 4

нц для k от 5 до 8

a := a + 2 * k

кц

вывод a

кон

Бейсик

DIM a, k AS INTEGER

a = 4

FOR k = 5 TO 8

a = a + 2 * k

NEXT k

PRINT a

Паскаль

var a, k : integer;

begin

a := 4;

for k := 5 to 8 do

a := a + 2 * k;

write(a);

end.


47. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмичекий

язык

алг

нач

  цел s,k

  s:= 0

  нц для k от 4 до 11

    s:=s + k

  кц

  вывод s

кон

 

Бейсик

dim s,k as integer

s  =  0

FOR k = 4 TO 11

s = s + k

NEXT k

PRINT   s

END

Паскаль

var s, k:integer;

begin

  s:= 0;

  for k:= 4 to 11 do

    s:= s + k;

  writeln (s);

end.              


48. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  цел s, i

  s := 3

  нц для i от 2 до 5

       s := s + 2*i

  кц

  вывод s

кон

 

Бейсик

DIM i,s AS INTEGER

s = 3

FOR i = 2 TO 5

s = s + 2*i

NEXT i

PRINT s

 

Паскаль

Var s,i:integer;

Begin

  s := 3;

  For i := 2 to 5 do

     s := s + 2*i;

  Writeln(s);

End.


49. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  цел s, n

  s := 5

  нц для n от 2 до 4

      s := s + (n-1)

  кц

  вывод s

кон

 

Бейсик

DIM s, n AS INTEGER

s = 5

FOR n = 2 TO 4

s = s + (n-1)

NEXT n

PRINT s

 

Паскаль

Var s,n: integer;

Begin

  s := 5;

  For n := 2 to 4 do

     s := s + (n-1);

  Writeln(s);

End.


50. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

цел n, s

s := 2

нц для n от 2 до 5

s := s + n * 2

кц

вывод s

кон

Бейсик

DIM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = s + n * 2

NEXT n

PRINT s

END

Паскаль

var s, n: integer;

begin

s := 2;

for n := 2 to 5 do

s := s + n * 2;

write(s);

end.


51. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

цел  n, s

s := 2

нц для n от 2 до 5

s := n + s * 2

кц

вывод s

кон

Бейсик

DIM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = n + s * 2

NEXT n

PRINT s

END

Паскаль

var s, n: integer;

begin

s := 2;

for n := 2 to 5 do

s := n + s * 2;

write(s);

end.


52. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  цел k,i

  k := 4

  нц для i от 1 до 3

        k := 2*k + i

  кц

  вывод k

кон

 

Бейсик

DIM i,k AS INTEGER

k = 4

FOR i = 1 TO 3

k = 2*k + i

NEXT i

PRINT k

 

Паскаль

Var k,i: integer;

Begin

  k := 4;

  For i := 1 to 3 do

     k := 2*k + i;

  Writeln(k);

End.

 

53. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

   цел y,i

   y := 0

   нц для i от 1 до 3

         y := y + 4*i

   кц

   вывод y

кон

Бейсик

DIM i,y AS INTEGER

y = 0

FOR i = 1 TO 3

y = y + 4*i

NEXT i

PRINT y

Паскаль

Var y,i: integer;

Begin

  y := 0;

  For i := 1 to 3 do

    y := y + 4*i;

  Writeln(y);

End.


54. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  цел d,n

  d := 6

  d := d-2

  нц для n от 1 до 4

        d := d + n

  кц

  вывод d

кон

Бейсик

DIM n,d AS INTEGER

d = 6

d = d-2

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

Паскаль

Var d,n: integer;

Begin

  d := 6;

  d := d-2;

  For n := 1 to 4 do

    d := d + n;

  Writeln(d);

End.


55. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  цел d,n

  d := 5

  d := d-3

  нц для n от 1 до 4

        d := d + n

  кц

  вывод d

кон

 

Бейсик

DIM n,d AS INTEGER

d = 5

d = d-3

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

 

Паскаль

Var d,n: integer;

Begin

  d := 5;

  d := d-3;

  For n := 1 to 4 do

    d := d + n;

  Writeln(d);

End.


56. Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел s, k

s := 0

нц для k от 3 до 8

s := s + 3 * k

кц

вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 0

FOR k = 3 TO 8

s = s + 3 * k

NEXT k

PRINT s

 

Паскаль

Var s, k : integer;

Begin

 s := 0;

 for k := 3 to 8 do

   s := s + 3 * k;

 write(s);

End.

 


57. Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  цел d,n,i

  n :=4

  d := n*2

  нц для i от 1 до 3

     d := d + 2*i

  кц

  вывод d

кон

 

DIM d,n,i AS INTEGER

n = 4

d = n*2

FOR i = 1 TO 3

d = d + 2*i

NEXT i

PRINT d

Var d,n,i:integer;

Begin

  n := 4;

  d := n*2;

  For i := 1 to 3 do

     d := d + 2*i;

  Writeln(d);

End.


58. Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

   цел d,n,i

   n :=3

   d := n*3

   нц для i от 1 до 3

         d := d + i

   кц

   вывод d

кон

 

DIM d,n,i AS INTEGER

n = 3

d = n*3

FOR i = 1 TO 3

d = d + i

NEXT i

PRINT d

Var d,n,i: integer;

Begin

  n := 3;

  d := n*3;

  For i := 1 to 3 do

     d := d + i;

  Writeln(d);

End.


59. Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трех языках программирования.

Алгоритмический язык

алг

нач

  цел s, k

  s:=1

  нц для k от 3 до 6

    s:=s * k

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 1

FOR k = 3 TO 6

 s = s * k

NEXT k

PRINT s

END

Паскаль

Var s,k: integer;

Begin

 s:=1;

 for k:=3 to 6 do

   s:=s * k;

 write(s);

End.

Форма входа
Поиск

Copyright MyCorp © 2017
Создать бесплатный сайт с uCoz