Суббота, 21.04.2018, 20:32
Приветствую Вас Гость | RSS

Подготовка к ГИА по информатике

Меню сайта
Статистика

задания типа 10 (часть 5)

24. В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2]  второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7

  Dat[2] := 9

  Dat[3] := 10

  Dat[4] := 5

  Dat[5] := 6

  Dat[6] := 7

  Dat[7] := 9

  Dat[8] := 8

  Dat[9] := 6

  Dat[10] := 9

  m := 10; n := 0

  нц для k от 1 до 10

    если Dat[k] < m то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

 

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7

Dat(2) = 9

Dat(3) = 10

Dat(4) = 5

Dat(5) = 6

Dat(6) = 7

Dat(7) = 9

Dat(8) = 8

Dat(9) = 6

Dat(10) = 9

m = 10: n = 0

FOR k = 1 TO 10

IF Dat(k) < m THEN

m = Dat(k)

n = k

ENDIF

NEXT k

PRINT n

 

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;

  Dat[2] := 9;

  Dat[3] := 10;

  Dat[4] := 5;

  Dat[5] := 6;

  Dat[6] := 7;

  Dat[7] := 9;

  Dat[8] := 8;

  Dat[9] := 6;

  Dat[10] := 9;

  m := 10; n := 0;

  for k := 1 to 10 do

    if  Dat[k] < m then

      begin

        m := Dat[k];

        n := k

      end;

  writeln(n)

End.

25. В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 12

  Dat[2] := 15

  Dat[3] := 17

  Dat[4] := 15

  Dat[5] := 14

  Dat[6] := 12

  Dat[7] := 10

  Dat[8] := 13

  Dat[9] := 14

  Dat[10] := 15

  m := 0

  нц для k от 1 до 10

    если Dat[k]=15 то

     m := m+1

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0 

FOR k = 1 TO 10

IF Dat(k)=15 THEN

m = m+1

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 12; Dat[2] := 15;

 Dat[3] := 17; Dat[4] := 15;

 Dat[5] := 14; Dat[6] := 12;

 Dat[7] := 10; Dat[8] := 13;

 Dat[9] := 14; Dat[10] := 15;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]=15 then

     begin

       m := m+1

     end;

 writeln(m);

End.


26. В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 12

  Dat[2] := 15

  Dat[3] := 17

  Dat[4] := 15

  Dat[5] := 14

  Dat[6] := 12

  Dat[7] := 10

  Dat[8] := 13

  Dat[9] := 14

  Dat[10] := 15

  m := 0

  нц для k от 1 до 10

    если Dat[k]>m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0 

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 12; Dat[2] := 15;

 Dat[3] := 17; Dat[4] := 15;

 Dat[5] := 14; Dat[6] := 12;

 Dat[7] := 10; Dat[8] := 13;

 Dat[9] := 14; Dat[10] := 15;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.

27. В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1]  данные за первый день, Dat[2]  за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 2

  Dat[2] := 5

  Dat[3] := 7

  Dat[4] := 5

  Dat[5] := 4

  Dat[6] := 2

  Dat[7] := 0

  Dat[8] := 2

  Dat[9] := 4

  Dat[10] := 5

  m := 0

  нц для k от 1 до 10

    если Dat[k]>3 то

     m := m+1

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 7: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 2

Dat(9) = 4:Dat(10) = 5

m = 0 

FOR k = 1 TO 10

IF Dat(k)>3 THEN

m = m+1

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 2; Dat[2] := 5;

 Dat[3] := 7; Dat[4] := 5;

 Dat[5] := 4; Dat[6] := 2;

 Dat[7] := 0; Dat[8] := 2;

 Dat[9] := 4; Dat[10] := 5;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>3 then

     begin

       m := m+1

     end;

 writeln(m);

End.

28. В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1]  количество голосов, поданных за первого исполнителя, Dat[2]  за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 16

  Dat[2] := 20

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 21

  Dat[7] := 28

  Dat[8] := 11

  Dat[9] := 15

  Dat[10] := 35

  m := 50

  нц для k от 1 до 10

    если Dat[k]<m то

     m := Dat[k]

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 11

Dat(9) = 15:Dat(10) = 35

m = 50 

FOR k = 1 TO 10

IF Dat(k)<m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 16; Dat[2] := 20;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 21;

 Dat[7] := 28; Dat[8] := 11;

 Dat[9] := 15; Dat[10] := 35;

 m := 50;

 for k := 1 to 10 do

   if  Dat[k]<m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.

29. В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1]  количество голосов, поданных за первого исполнителя, Dat[2]  за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 16

  Dat[2] := 20

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 21

  Dat[7] := 28

  Dat[8] := 12

  Dat[9] := 15

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]<25 то

     m := m+1

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 12

Dat(9) = 15:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)<25 THEN

m = m+1

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 16; Dat[2] := 20;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 21;

 Dat[7] := 28; Dat[8] := 12;

 Dat[9] := 15; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]<25 then

     begin

       m := m+1

     end;

 writeln(m);

End.

30. В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1]  данные за первый день, Dat[2]  за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 2

  Dat[2] := 5

  Dat[3] := 7

  Dat[4] := 5

  Dat[5] := 4

  Dat[6] := 2

  Dat[7] := 0

  Dat[8] := 3

  Dat[9] := 4

  Dat[10] := 5

  m := 10

  нц для k от 1 до 10

    если Dat[k]<m то

     m := Dat[k]

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 7: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 3

Dat(9) = 4:Dat(10) = 5

m = 10 

FOR k = 1 TO 10

IF Dat(k)<m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 2; Dat[2] := 5;

 Dat[3] := 7; Dat[4] := 5;

 Dat[5] := 4; Dat[6] := 2;

 Dat[7] := 0; Dat[8] := 3;

 Dat[9] := 4; Dat[10] := 5;

 m := 10;

 for k := 1 to 10 do

   if  Dat[k]<m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.

31. В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1]  данные за первый день, Dat[2]  за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 2

  Dat[2] := 5

  Dat[3] := 8

  Dat[4] := 5

  Dat[5] := 4

  Dat[6] := 2

  Dat[7] := 0

  Dat[8] := 3

  Dat[9] := 4

  Dat[10] := 5

  m := 0

  нц для k от 1 до 10

    если Dat[k]>m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 8: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 3

Dat(9) = 4:Dat(10) = 5

m = 0 

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 2; Dat[2] := 5;

 Dat[3] := 8; Dat[4] := 5;

 Dat[5] := 4; Dat[6] := 2;

 Dat[7] := 0; Dat[8] := 3;

 Dat[9] := 4;Dat[10] := 5;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


32. В таблице Dat хранятся данные о количестве учеников в классах (Dat[1]  количество учеников в первом классе, Dat[2]  во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20

  Dat[2] := 27

  Dat[3] := 19

  Dat[4] := 28

  Dat[5] := 26

  Dat[6] := 22

  Dat[7] := 24

  Dat[8] := 28

  Dat[9] := 26

  Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] < 25 то

     m := m+1

    все

  кц

  вывод m

кон

 

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20

Dat(2) = 27

Dat(3) = 19

Dat(4) = 28

Dat(5) = 26

Dat(6) = 22

Dat(7) = 24

Dat(8) = 28

Dat(9) = 26

Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) < 25 THEN

m = m+1

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;

  Dat[2] := 27;

  Dat[3] := 19;

  Dat[4] := 28;

  Dat[5] := 26;

  Dat[6] := 22;

  Dat[7] := 24;

  Dat[8] := 28;

  Dat[9] := 26;

  Dat[10] := 21;

  Dat[11] := 27

  m := 0;

  for k := 1 to 11 do

    if  Dat[k] < 25 then

      begin

        m := m+1

      end;

  writeln(m)

End.

 33. В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1]  количество голосов, поданных за первого исполнителя, Dat[2]  за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 56

  Dat[2] := 70

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 22

  Dat[7] := 30

  Dat[8] := 12

  Dat[9] := 65

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]>25 то

     m := m+1

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)>25 THEN

m = m+1

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 56; Dat[2] := 70;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 22;

 Dat[7] := 30; Dat[8] := 12;

 Dat[9] := 65; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>25 then

     begin

       m := m+1

     end;

 writeln(m);

End.

Форма входа
Поиск

Copyright MyCorp © 2018
Создать бесплатный сайт с uCoz