Воскресенье, 16.12.2018, 23:36
Приветствую Вас Гость | RSS

Подготовка к ГИА по информатике

Меню сайта
Статистика

задания типа 10 (часть 6)

34. В таблице Dat хранятся данные ежедневных измерений количества осадков за неделю в миллиметрах (Dat[1]  данные за понедельник, Dat[2]  за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

 

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, m, day

Dat[1] := 14;

Dat[2] := 10

Dat[3] := 0; Dat[4] := 15

Dat[5] := 0;  Dat[6] := 15

Dat[7] := 10

day := 1; m := Dat[1]

нц для k от 2 до 7

если Dat[k] > m то

m := Dat[k]; day := k

все

кц

вывод day

кон

Бейсик

DIM Dat(7) AS INTEGER

Dat(1) = 14:  Dat(2) = 10

Dat(3) = 0: Dat(4) = 15

Dat(5) = 0:  Dat(6) = 15

Dat(7) = 10

day = 1: m = Dat(1)

FOR k = 2 TO 7

IF Dat(k) > m THEN

m = Dat(k)

day = k

END IF

NEXT k

PRINT day

END

Паскаль

var k, m, day: integer;

Dat: array[1..7] of integer;

begin

Dat[1] := 14;  Dat[2] := 10;

Dat[3] := 0; Dat[4] := 15;

Dat[5] := 0;  Dat[6] := 15;

Dat[7] := 10; 

day := 1; m := Dat[1];

for k := 2 to 7 do begin

if  Dat[k] > m then begin

m := Dat[k]; day := k

end;

end;

write(day);

end.


35. В таблице Ball хранятся баллы, набранные участниками школьного тура олимпиады по математике (Ball[1]  балл 1 ученика, Ball[2]  балл 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

алг

нач

целтаб Ball[1:10]

цел k, m, t

Ball[1]:=12; Ball[2]:=25

Ball[3]:=13; Ball[4]:=18

Ball[5]:=35; Ball[6]:=55

Ball[7]:=48; Ball[8]:=33

Ball[9]:=64; Ball[10]:=45

m := Ball[1]; t := 1

нц для k от 1 до 10

если Ball[k] > m то

m := Ball[k]; t := k

все

кц

вывод t

кон

 

Бейсик

DIM Ball(10) AS INTEGER

DIM k, m, t AS INTEGER

Ball(1)=12: Ball(2)=25

Ball(3)=13: Ball(4)=18

Ball(5)=35: Ball(6)=55

Ball(7)=48: Ball(8)=33

Ball(9)=64: Ball(10)=45

m = Ball(1): t = 1

FOR k = 1 TO 10

IF Ball(k) > m THEN

m = Ball(k): t = k

END IF

NEXT k

PRINT t

Паскаль

Var k, m, t: integer;

Ball: array[1..10] of integer;

Begin

Ball[1]:=12; Ball[2]:=25;

Ball[3]:=13; Ball[4]:=18;

Ball[5]:=35; Ball[6]:=55;

Ball[7]:=48; Ball[8]:=33;

Ball[9]:=64; Ball[10]:=45;

m := Ball[1]; t := 1;

for k := 1 to 10 do

if Ball[k] > m then begin

m := Ball[k]; t := k

end;

write(t);

End.


36. В таблице Dat хранятся данные ежедневных измерений количества осадков за неделю в миллиметрах (Dat[1]  данные за понедельник, Dat[2]  за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, day

Dat[1] := 14;  Dat[2] := 10

Dat[3] := 0; Dat[4] := 15

Dat[5] := 0;  Dat[6] := 15

Dat[7] := 10

day := 0;

нц для k от 1 до 7

если Dat[k] = 0 то

day := k

все

кц

вывод day

кон

Бейсик

DIM Dat(7) AS INTEGER

Dat(1) = 14:  Dat(2) = 10

Dat(3) = 0: Dat(4) = 15

Dat(5) = 0:  Dat(6) = 15

Dat(7) = 10

day = 0

FOR k = 1 TO 7

IF Dat(k) = 0 THEN

day=k

ENDIF

NEXT k

PRINT day

END

Паскаль

var k, day: integer;

Dat: array[1..7] of integer;

begin

Dat[1] := 14;  Dat[2] := 10;

Dat[3] := 0; Dat[4] := 15;

Dat[5] := 0;  Dat[6] := 15;

Dat[7] := 10; 

day := 0;

for k := 1 to 7 do

if  Dat[k] = 0 then

day := k;

write(day);

end.

37. В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1]  количество голосов, поданных за первого исполнителя, Dat[2]  за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 56

  Dat[2] := 70

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 22

  Dat[7] := 30

  Dat[8] := 12

  Dat[9] := 65

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]>m то

     m := Dat[k]

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 56; Dat[2] := 70;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 22;

 Dat[7] := 30; Dat[8] := 12;

 Dat[9] := 65; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


38. В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1]  данные за первый день, Dat[2]  за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 12

  Dat[2] := 15

  Dat[3] := 17

  Dat[4] := 15

  Dat[5] := 14

  Dat[6] := 12

  Dat[7] := 10

  Dat[8] := 13

  Dat[9] := 14

  Dat[10] := 15

  m := 0

  нц для k от 1 до 10

    если Dat[k]>12 то

     m := m+1

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0 

FOR k = 1 TO 10

IF Dat(k)>12 THEN

m = m+1

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 12; Dat[2] := 15;

 Dat[3] := 17; Dat[4] := 15;

 Dat[5] := 14; Dat[6] := 12;

 Dat[7] := 10; Dat[8] := 13;

 Dat[9] := 14; Dat[10] := 15;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>12 then

     begin

       m := m+1

     end;

 writeln(m);

End.

39. В таблице Pos хранятся данные о количестве посетителей школьного музея за семь дней (Pos[1]  данные за первый день, Pos[2]  за второй день и т.д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

 целтаб Pos[1:7]

 цел  k, m, day

 Pos[1] := 17

 Pos[2] := 19

 Pos[3] := 20

 Pos[4] := 18

 Pos[5] := 16

 Pos[6] := 20

 Pos[7] := 16

 day:= 1

 m:=Pos[1]

 нц для k от 2 до 7

  если Pos[k] > m то

    m:=Pos[k]

    day:=k

  все

 кц

 вывод day

кон

DIM Pos(7)AS INTEGER

 Pos(1) = 17

 Pos(2) = 19

 Pos(3) = 20

 Pos(4) = 18

 Pos(5) = 16

 Pos(6) = 20

 Pos(7) = 16

 day = 1

 m = Pos(1)

FOR k = 2 TO 7

 IF Pos(k) > m THEN

   m = Pos(k)

   day = k

 END IF

NEXT k

PRINT day

END

 

Var k, m, day: integer;

 Pos: array[1..7] of integer;

Begin

 Pos[1] := 17; 

 Pos[2] := 19;

 Pos[3] := 20;

 Pos[4] := 18;

 Pos[5] := 16; 

 Pos[6] := 20;

 Pos[7] := 16; 

 day := 1; m := Pos[1];

 for k:=2 to 7 do begin

   if  Pos[k] > m then

     begin

       m := Pos[k];

       day := k

     end

 end;

 write(day);

End.

40. В таблице Pos хранятся данные о количестве посетителей школьного музея за семь дней (Pos[1]  данные за первый день, Pos[2]  за второй день и т.д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

алг

нач

 целтаб Pos[1:7]

 цел  k, m, day

 Pos[1] := 17

 Pos[2] := 19

 Pos[3] := 20

 Pos[4] := 18

 Pos[5] := 16

 Pos[6] := 20

 Pos[7] := 16

 day:= 1

 m:=Pos[1]

 нц для k от 2 до 7

  если Pos[k] < m то

    m := Pos[k]

    day := k

  все

 кц

 вывод day

кон

DIM Pos(7)AS INTEGER

 Pos(1) = 17

 Pos(2) = 19

 Pos(3) = 20

 Pos(4) = 18

 Pos(5) = 16

 Pos(6) = 20

 Pos(7) = 16

 day = 1

 m = Pos(1)

FOR k = 2 TO 7

 IF Pos(k) < m THEN

   m = Pos(k)

   day = k

 END IF

NEXT k

PRINT day

END

 

Var k, m, day: integer;

 Pos: array[1..7] of integer;

Begin

 Pos[1] := 17; 

 Pos[2] := 19;

 Pos[3] := 20;

 Pos[4] := 18;

 Pos[5] := 16; 

 Pos[6] := 20;

 Pos[7] := 16; 

 day := 1; m := Pos[1];

 for k:=2 to 7 do begin

   if  Pos[k] < m then

     begin

       m := Pos[k];

       day := k

     end

 end;

 write(day);

End.

41. В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1]  данные за понедельник, Dat[2]  за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх алгоритмических языках.

 

Алгоритмический язык

алг

нач

   целтаб Dat[1:7]

   цел  k, m, day

   Dat[1]:=7;  Dat[2]:=9

   Dat[3]:=10; Dat[4]:=8

   Dat[5]:=6;  Dat[6]:=7

   Dat[7]:=6

   day:= 1; m:=Dat[1]

     нц для k от 2 до 7

         если Dat[k] < m то

     m:=Dat[k]; day:=k

         все

     кц

     вывод day

кон

 

Бейсик

DIM Dat(7) AS INTEGER

Dat(1)=7:  Dat(2)=9

Dat(3)=10: Dat(4)=8

Dat(5)=6:  Dat(6)=7

Dat(7)=6

day = 1: m=Dat(1)

FOR k = 2 TO 7

IF Dat(k) < m THEN

m=Dat(k)

day=k

END IF

NEXT k

PRINT day

END

Паскаль

Var k, m, day: integer;

 Dat: array[1..7] of integer;

Begin

   Dat[1]:=7;  Dat[2]:=9;

   Dat[3]:=10; Dat[4]:=8;

   Dat[5]:=6;  Dat[6]:=7;

   Dat[7]:=6; 

   day:= 1; m:=Dat[1];

   for k:=2 to 7 do begin

      if  Dat[k] < m then begin

          m:=Dat [k]; day:=k

      end

   end

    write(day);

End.

42. В таблице Dat хранятся данные о количестве учеников в классах (Dat[1]  количество учеников в первом классе, Dat[2]  во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] > 22 то

     m := m + 1

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) > 22 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  Dat[k] > 22 then

      begin

        m := m + 1

      end;

  writeln(m)

End.

43. В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2]  второй и т.д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1]:=7; Dat[2]:=9

  Dat[3]:=10; Dat[4]:=5

  Dat[5]:=6; Dat[6]:=7

  Dat[7]:=9; Dat[8]:=8

  Dat[9]:=6; Dat[10]:=9

  m:=10;n=0

  нц для k от 1 до 10

    если Dat[k] <= m  то

     m:=Dat[k];n:=k

    все

  кц

  вывод m

кон

 

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1)=7:  Dat(2)=9

Dat(3)=10: Dat(4)=5

Dat(5)=6:  Dat(6)=7

Dat(7)=9:  Dat(8)=8

Dat(9)=6:  Dat(10)=9

m = 10: n=0

FOR k = 1 TO 10

IF Dat(k) <= m THEN

m=Dat(k)

n=k

END IF

NEXT k

PRINT m

 

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 10; n = 0;

  for k := 1 to 10 do

    if  Dat[k] <= m then

      begin

        m := Dat[k]; n := k

      end;

  writeln(m);

End.

44. В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1]  количество голосов, поданных за первого исполнителя, Dat[2]  за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 56

  Dat[2] := 70

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 22

  Dat[7] := 30

  Dat[8] := 12

  Dat[9] := 65

  Dat[10] := 35

  m := 100

  нц для k от 1 до 10

    если Dat[k]<m то

     m := Dat[k]

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65:Dat(10) = 35

m = 100 

FOR k = 1 TO 10

IF Dat(k)<m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

 

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 56; Dat[2] := 70;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 22;

 Dat[7] := 30; Dat[8] := 12;

 Dat[9] := 65; Dat[10] := 35;

 m := 100;

 for k := 1 to 10 do

   if  Dat[k]<m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.

Форма входа
Поиск

Copyright MyCorp © 2018
Создать бесплатный сайт с uCoz