Среда, 20.09.2017, 17:31
Приветствую Вас Гость | RSS

Подготовка к ГИА по информатике

Меню сайта
Статистика

задания типа 20 (часть 21)

62.  Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды 

 это команды-приказы:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →.
Если Робот получит команду передвижения через стену, то он разрушится. 
Ещё четыре команды 

 это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно
снизу свободно
слева свободно
справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

Здесь условие 

 одна из команд проверки условия.
Последовательность команд 

 это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и не (снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие 
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

Выполните задание.

На бесконечном поле имеется стена, длины отрезков стены неизвестны. Стена состоит из трёх последовательных отрезков: вправо, вниз, вправо, все отрезки неизвестной длины. Робот находится в клетке, расположенной сверху левого конца первого отрезка.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные правее второго отрезка и над третьим. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).
undefined

Конечное расположение Робота может быть произвольным.
Алгоритм должен решать задачу для бесконечного поля и любого допустимого расположения стен. При исполнении алгоритма Робот не должен разрушиться.




63. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды 

 это команды-приказы:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →.
Если Робот получит команду передвижения через стену, то он разрушится. 
Ещё четыре команды 

 это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно
снизу свободно
слева свободно
справа свободно
Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

Здесь условие 

 одна из команд проверки условия.

Последовательность команд 

 это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и не (снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие 
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент. 

Выполните задание.
На бесконечном поле имеется стена, длины отрезков стены неизвестны. Стена состоит из трёх последовательных отрезков: вправо, вниз, вправо, все отрезки неизвестной длины. Робот находится в клетке, расположенной над левым концом первого отрезка. На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные над первым отрезком и справа от второго. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

undefined

 

Конечное расположение Робота может быть произвольным.

Алгоритм должен решать задачу для бесконечного поля и любого допустимого расположения стен. При исполнении алгоритма Робот не должен разрушиться.




64. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. У Робота есть четыре команды перемещения:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →.

Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится.

Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот:

сверху свободно

снизу свободно

слева свободно

справа свободно


Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то

последовательность команд

все

 

«Последовательность команд» 

 это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то

вправо

все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

вправо

кц

 

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

 

Выполните задание.

На бесконечном поле имеется стена, состоящая из трёх последовательных отрезков: вправо, вниз, влево. Все отрезки неизвестной длины. Робот находится в клетке, расположенной в нижнем углу, который образуется вторым и третьим отрезком.

На рисунке указан один из возможных способов расположения стены и Робота (Робот обозначен буквой «Р»).

undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные ниже третьего отрезка. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

undefined

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для бесконечного поля и любого допустимого расположения стен. При исполнении алгоритма Робот не должен разрушиться.




65. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. У Робота есть четыре команды перемещения:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится.

Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот:

сверху свободно

снизу свободно

слева свободно

справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид: если условие то

последовательность команд

все

 

«Последовательность команд» 

 это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то

вправо

все

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, илине, например:

если (справа свободно) и (не снизу свободно) то

вправо

все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

вправо

кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

 

Выполните задание.

На бесконечном поле имеется стена, состоящая из трёх последовательных отрезков: вправо, вниз, влево. Все отрезки неизвестной длины. Робот находится в клетке, расположенной в нижнем углу, который образуется вторым и третьим отрезком.

На рисунке указан один из возможных способов расположения стены и Робота (Робот обозначен буквой «Р»).

 

undefined 
 

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные справа от второго отрезка. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).


undefined 

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для бесконечного поля и любого допустимого расположения стен. При исполнении алгоритма Робот не должен разрушиться.

Форма входа
Поиск

Copyright MyCorp © 2017
Создать бесплатный сайт с uCoz