Понедельник, 11.12.2017, 16:16
Приветствую Вас Гость | RSS

Подготовка к ГИА по информатике

Меню сайта
Статистика

задания типа 20 (часть 20)

60. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды 
 это команды-приказы:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →.
Если Робот получит команду передвижения через стену, то он разрушится. 
Ещё четыре команды 

 это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно
снизу свободно
слева свободно
справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

Здесь условие 

 одна из команд проверки условия.
Последовательность команд 
 это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и не (снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока  условие 
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

 

Выполните задание.

На бесконечном поле имеются четыре стены, расположенные в форме прямоугольника. Длины вертикальных и горизонтальных стен неизвестны. Робот находится в клетке, расположенной в левом верхнем углу прямоугольника.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

undefined undefined  

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные с внутренней стороны правой и нижней стен. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

undefined undefined

Конечное расположение Робота может быть произвольным.
Алгоритм должен решать задачу для бесконечного поля и любого допустимого расположения стен. При исполнении алгоритма Робот не должен разрушиться.




61. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. У Робота есть девять команд. Четыре команды 

 это команды-приказы:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →.
Если Робот получит команду передвижения через стену, то он разрушится. 
Ещё четыре команды 

 это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно
снизу свободно
слева свободно
справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

Здесь условие 

 одна из команд проверки условия.
Последовательность команд 

 это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и не (снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока  условие 
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

 
Выполните задание.

На бесконечном поле имеются 4 стены, расположенные в форме прямоугольника. Длины вертикальных и горизонтальных стен неизвестны. Робот находится в клетке, расположенной в левом верхнем углу прямоугольника.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р») .

undefined undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные с внутренней стороны верхней и нижней стен. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

undefined undefined

Конечное расположение Робота может быть произвольным.
Алгоритм должен решать задачу для бесконечного поля и любого допустимого расположения стен. При исполнении алгоритма Робот не должен разрушиться.



 

Форма входа
Поиск

Copyright MyCorp © 2017
Создать бесплатный сайт с uCoz