Понедельник, 21.05.2018, 17:49
Приветствую Вас Гость | RSS

Подготовка к ГИА по информатике

Меню сайта
Статистика

задания типа 20 (часть 19)

56. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Ниже приведено описание Робота. У Робота есть четыре команды перемещения:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →.

Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится. Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот:

сверху свободно
снизу свободно
слева свободно
справа свободно

 

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

 

«Последовательность команд» 

 это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

логические связки и, или, не, например:

если (справа свободно) и (не снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока  условие 
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

 

Выполните задание.

На бесконечном поле имеется стена, состоящая из 5 последовательных отрезков, расположенных змейкой: вправо, вниз, влево, вниз, вправо, все отрезки неизвестной длины. Робот находится в клетке, расположенной снизу от левого края первой горизонтальной стены.

На рисунке указан один из возможных способов расположения стен

и Робота (Робот обозначен буквой «Р») .

undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные ниже первого и левее второго отрезков стены и левее четвертого и ниже пятого отрезков стены. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок)

undefined

Конечное расположение Робота может быть произвольным.

Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен внутри прямоугольного поля. При исполнении алгоритма Робот не должен разрушиться.



57. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Ниже приведено описание Робота. 
У Робота есть четыре команды перемещения:
вверх
вниз
влево
вправо
При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑, вниз ↓, влево ←, вправо →.
Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится.

Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот:

сверху свободно
снизу свободно
слева свободно
справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

Последовательность команд 

 это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

В одном условии можно использовать несколько команд проверки условий логические связки иили, не, например:

если (справа свободно) и (не снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока  условие 
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

 

Выполните задание.

На бесконечном поле имеется стена, состоящая из 5 последовательных отрезков, расположенных змейкой: вниз, вправо, вверх, вправо, вниз. Все отрезки неизвестной длины. Робот находится в клетке, расположенной слева от верхнего края первой вертикальной стены.
На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные левее первого и ниже второго отрезков стены и ниже четвёртого и левее пятого отрезков стены. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

 undefined

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен внутри прямоугольного поля. При исполнении алгоритма Робот не должен разрушиться.




58. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Ниже приведено описание Робота. У Робота есть четыре команды перемещения:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку
соответственно: вверх ↑, вниз ↓, влево ←, вправо →.
Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится.

Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот:

сверху свободно
снизу свободно
слева свободно
справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

«Последовательность команд» 

 это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

В одном условии можно использовать несколько команд проверки условий,

применяя логические связки и, или, не, например:

если (справа свободно) и не (снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

Выполните задание.

На бесконечном поле имеется лестница. Сначала лестница спускается вниз слева направо, потом поднимается вверх также слева направо. После подъема лестница переходит в вертикальную стену. Высота каждой ступени 1 клетка, ширина 

 1 клетка. Количество ступенек, ведущих вверх, и количество ступенек, ведущих вниз, неизвестно. Между спуском и подъемом ширина площадки 1 клетка.

Робот находится в клетке, расположенной в начале спуска.
На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

undefined undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно над лестницей, как показано на рисунке. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

undefined

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для бесконечного поля и любого количества ступеней. При исполнении алгоритма Робот не должен разрушиться.



 

59. Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Ниже приведено описание Робота. У Робота есть четыре команды перемещения:

вверх
вниз
влево
вправо

При выполнении любой из этих команд Робот перемещается на одну клетку
соответственно: вверх ↑, вниз ↓, влево ←, вправо →.
Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может. Если Робот получит команду передвижения через стену, то он разрушится.

Четыре команды проверяют истинность условия отсутствия стены у каждой стороны той клетки, где находится Робот:

сверху свободно
снизу свободно
слева свободно
справа свободно

Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:

если условие то
последовательность команд
все

«Последовательность команд» 

 это одна или несколько любых команд, выполняемых Роботом. Например, для передвижения на одну клетку вправо, если справа нет стенки, можно использовать такой алгоритм:

если справа свободно то
вправо
все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и не (снизу свободно) то
вправо
все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие
последовательность команд
кц

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно
вправо
кц

Также у Робота есть команда закрасить, закрашивающая клетку, в которой Робот находится в настоящий момент.

Выполните задание.

На бесконечном поле имеется лестница. Сначала лестница поднимается вверх слева направо, потом опускается вниз также слева направо. Правее спуска лестница переходит в горизонтальную стену. Высота каждой ступени 1 клетка, ширина 

 1 клетка. Количество ступенек, ведущих вверх, и количество ступенек, ведущих вниз, неизвестно. Между подъемом и спуском ширина площадки 1 клетка. Робот находится в клетке, расположенной в начале подъема.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р») .

undefined undefined

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные непосредственно над лестницей. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

undefined undefined

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для бесконечного поля и любого количества ступеней. При исполнении алгоритма Робот не должен разрушиться.
 


 

Форма входа
Поиск

Copyright MyCorp © 2018
Создать бесплатный сайт с uCoz