Понедельник, 11.12.2017, 16:21
Приветствую Вас Гость | RSS

Подготовка к ГИА по информатике

Меню сайта
Статистика

задания типа 10 (часть 7)

45. В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1]  данные за понедельник, Dat[2]  за вторник и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:7]

  цел k, m

  Dat[1]:=15; Dat[2]:=18

  Dat[3]:=22; Dat[4]:=20

  Dat[5]:=23; Dat[6]:=24

  Dat[7]:=20

  m:= 0

  нц для k от 1 до 7

    если Dat[k] >20 то

      m:=m+1

    все

  кц

  вывод m

кон

 

Бейсик

DIM Dat(7) AS INTEGER

Dat(1)=15: Dat(2)=18

Dat(3)=22: Dat(4)=20

Dat(5)=23: Dat(6)=24

Dat(7)=20

m = 0

FOR k = 1 TO 7

IF Dat(k) >20 THEN

m=m+1 :

END IF

NEXT k

PRINT m

END

 

Паскаль

Var k, m: integer;

Dat: array[1..7] of integer;

Begin

  m:=0;

  Dat[1]:=15; Dat[2]:=18;

  Dat[3]:=22; Dat[4]:=20;

  Dat[5]:=23; Dat[6]:=24;

  Dat[7]:=20;

  for k:=1 to 7 do begin

    if Dat[k] >20 then

      m:=m+1;

  end

  write(m);

End.


46. В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1]  данные за понедельник, Dat[2]  за вторник и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:7]

  цел k, m

  Dat[1]:=2; Dat[2]:=1

  Dat[3]:=2; Dat[4]:=4

  Dat[5]:=0; Dat[6]:=1

  Dat[7]:=4

  m:= 0

  нц для k от 1 до 7

    если Dat[k] < 0 то

      m:=m+1

    все

  кц

  вывод m

кон

 

Бейсик

DIM Dat(7) AS INTEGER

Dat(1)=-2: Dat(2)=-1

Dat(3)=2: Dat(4)=4

Dat(5)=0: Dat(6)=-1

Dat(7)=-4

m = 0

FOR k = 1 TO 7

IF Dat(k) < 0 THEN

m=m+1 :

END IF

NEXT k

PRINT m

END

 

Паскаль

Var k, m: integer;

Dat: array[1..7] of integer;

Begin

  m:=0;

  Dat[1]:=-2; Dat[2]:=-1;

  Dat[3]:=2; Dat[4]:=4;

  Dat[5]:=0; Dat[6]:=-1;

  Dat[7]:=-4;

  for k:=1 to 7 do begin

    if Dat[k] < 0 then

      m:=m+1;

  end

  write(m);

End.


47. В таблице Ball хранятся отметки по контрольной работе (Ball[1]  отметка 1 ученика, Ball[2]  отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Ball[1:10]

  цел k, c

  Ball[1]:=4; Ball[2]:=5

  Ball[3]:=3; Ball[4]:=4

  Ball[5]:=2; Ball[6]:=5

  Ball[7]:=4; Ball[8]:=3

  Ball[9]:=4; Ball[10]:=5

  c:= 0

  нц для k от 1 до 10

    если Ball[k] >3 то

      c:=c+1

    все

  кц

  вывод c

кон

 

Бейсик

DIM Ball(10) AS INTEGER

DIM k, c AS INTEGER

Ball(1)=4: Ball(2)=5

Ball(3)=3: Ball(4)=4

Ball(5)=2: Ball(6)=5

Ball(7)=4: Ball(8)=3

Ball(9)=4: Ball(10)=5

c = 0

FOR k = 1 TO 10

IF Ball(k) >3 THEN

c=c+1

ENDIF

NEXT k

PRINT c

END

 

Паскаль

Var k, c: integer;

Ball: array[1..10] of integer;

Begin

  c:=0;

  Ball[1]:=4; Ball[2]:=5;

  Ball[3]:=3; Ball[4]:=4;

  Ball[5]:=2; Ball[6]:=5;

  Ball[7]:=4; Ball[8]:=3;

  Ball[9]:=4; Ball[10]:=5;

  for k:=1 to 10 do begin

    if Ball[k] >3 then

      c:=c+1;

  end;

  write(c);

End.

В В В 

48 В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2]  второй и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 10

  Dat[9] := 6; Dat[10] := 9

  m := 0; n = 0

  нц для k от 1 до 10

    если Dat[k] >= m  то

     m := Dat[k]; n := k

    все

  кц

  вывод m

кон

 

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 10

Dat(9) = 6:  Dat(10) = 9

m = 0: n = 0

FOR k = 1 TO 10

IF Dat(k) >= m THEN

m = Dat(k)

n = k

END IF

NEXT k

PRINT m

 

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 10;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0; n := 0;

  for k := 1 to 10 do

    if  Dat[k] >= m then

      begin

        m := Dat[k]; n := k

      end;

  writeln(m);

End.

Форма входа
Поиск

Copyright MyCorp © 2017
Создать бесплатный сайт с uCoz